1. These forums are still being retired! Please use GitHub discussions or Discord. You cannot create new threads or new accounts now. If you need to contact some user of the forums, you should do it sooner, rather than later. This notice was last updated on May 30th, 2021.

Resolved Cannot start server console

Discussion in 'Help and Support' started by danielisacrab, Oct 1, 2013.

Thread Status:
Not open for further replies.
  1. danielisacrab

    danielisacrab Level 0

    Joined:
    Oct 1, 2013
    Messages:
    2
    Hi guys,
    just trying out TShock 4.2 R4, but i can't seem to get it working. Below is my console output:

    X:\Desktop\tshock4.2>TerrariaServer.exe -ip 0.0.0.0 -port 15555
    [Server API] Error Server crashed due to an unhandled exception:
    System.TypeInitializationException: The type initializer for 'Terraria.Main' th
    ew an exception. ---> System.TypeInitializationException: The type initializer
    or 'Terraria.Netplay' threw an exception. ---> System.Net.Sockets.SocketExcepti
    n: An invalid argument was supplied
    at System.Net.Sockets.Socket..ctor(AddressFamily addressFamily, SocketType s
    cketType, ProtocolType protocolType)
    at System.Net.Sockets.TcpClient.initialize()
    at System.Net.Sockets.TcpClient..ctor(AddressFamily family)
    at System.Net.Sockets.TcpClient..ctor()
    at Terraria.ClientSock..ctor()
    at Terraria.Netplay..cctor()
    --- End of inner exception stack trace ---
    at Terraria.Main..cctor()
    --- End of inner exception stack trace ---
    at Terraria.Main..ctor()
    at Terraria.ProgramServer.Main(String[] args)

    Port 15555 is not in use, confirmed by netstat.

    Any help would be greatly appreciated.
     
  2. nicatronTg

    nicatronTg Shank / hakusaro
    TShock Founder TShock Admin

    Joined:
    Jul 21, 2011
    Messages:
    723
    Does it start without the port definition?
     
  3. k0rd

    k0rd Tee Shawk Developer
    TShock Admin

    Joined:
    Dec 22, 2011
    Messages:
    438
    I cannot confirm - TerrariaServer.exe -ip 0.0.0.0 -port 15555 works okay here.
     
  4. Olink

    Olink Admin note: Actually a really nice person now

    Joined:
    Jul 21, 2011
    Messages:
    1,397
    Works for me. Did you update the exe?
     
  5. danielisacrab

    danielisacrab Level 0

    Joined:
    Oct 1, 2013
    Messages:
    2
    Seems to be just an issue with my testing server, works on another box fine :)
     
Thread Status:
Not open for further replies.