1. These forums are still being retired! Please use GitHub discussions or Discord. You cannot create new threads or new accounts now. If you need to contact some user of the forums, you should do it sooner, rather than later. This notice was last updated on May 30th, 2021.

Resolved default/guest group cannot move npcs or summon bosses

Discussion in 'Help and Support' started by langlotegate, Jul 11, 2017.

Tags:
  1. langlotegate

    langlotegate Level 0

    Joined:
    Jul 11, 2017
    Messages:
    2
    Despite using 'addperm' and 'del perm' and verifying if those commands have actually worked by 'listperm', users that join are unable to summon bosses or move npcs. (Those two permissions are the only ones that I've tried that don't work) Adding other permissions such as "tshock.item.give" to the guest group works fine. Changing the text color of the group has confirmed that the players are really in the guest group.. I'm at a bit of a loss as of what to do.

    If I give the guest group " * " permission they can move npcs and summon bosses, but take that away and leave just the specific permissions and they can't..

    I'm running tshock on a linux machine using Mono.
    I must mention that it has been a bit temperamental.. Sometimes not accepting commands as valid but repeating the absolute identical command a second time works.

    Any advice would be much appreciated,
     
  2. Zaicon

    Zaicon Spam Cleaner 9000
    TShock Mod Plugin Developer

    Joined:
    Feb 15, 2014
    Messages:
    811
    I went ahead and tested both of those permissions using the guest group (and a new group just to be sure), but they both seem to be working correctly for me. For the boss-spawning permission, remember that there's two different permissions: one to use /spawnboss, and the other to use spawners (Suspicious Looking Eye, etc).
     
  3. langlotegate

    langlotegate Level 0

    Joined:
    Jul 11, 2017
    Messages:
    2
    Hey! Thanks for testing that on your side. I was aware of the two different commands, one for using /spawnboss and the other for using the items.
    I just did a fresh reinstall of the server and it works fine now. I probably should have tried that before posting here but anyway.

    Thanks so much for replying so quickly and making sure it wasn't an actual game bug.

    Cheers,