Bug? Server lags Linux

Discussion in 'Help and Support' started by Danil123, Dec 8, 2018 at 9:28 AM.

Tags:
  1. Danil123

    Danil123 Level 1

    Joined:
    Saturday
    Messages:
    5
    I started the server on my dedicated server, however I noticed the freezing of mobs and players.
    Count players: 4-5
    OC: Debian 7
    TShock v4.3.25
    Xeon E3-1245v2 (3.4GHz) 6 vCore | 12GB Ram
    [​IMG]

    Plugins:
    [​IMG]
     
    #1 Danil123, Dec 8, 2018 at 9:28 AM
    Last edited: Dec 8, 2018 at 9:36 AM
  2. Incorrect Username

    Joined:
    Dec 27, 2011
    Messages:
    6
    Who are you getting your VPS from? What does htop say? Have you done a speedtest on your box? The CPU seems ok, shouldn't have a bottleneck, htop would show it anyway. Sounds like a bandwidth issue.

    sudo apt-get htop
     
  3. Danil123

    Danil123 Level 1

    Joined:
    Saturday
    Messages:
    5
    Yes, I forgot to throw it.

    [​IMG]
     
  4. Danil123

    Danil123 Level 1

    Joined:
    Saturday
    Messages:
    5
    Poland. OVH.
     
  5. Incorrect Username

    Joined:
    Dec 27, 2011
    Messages:
    6
    Have you tried shutting off your minecraft server while you test to see if its still lagging? What does your RAM peak to?

    *edit just saw your post* Are you and the other players connecting close to poland or from a different country?
     
  6. Danil123

    Danil123 Level 1

    Joined:
    Saturday
    Messages:
    5
    At the time of the game, the Minecraft server was not running, yes, in the screenshot, the RAM was directed to the game servers of minecraft, but this is only at the time of the screenshot.
     
  7. Danil123

    Danil123 Level 1

    Joined:
    Saturday
    Messages:
    5
    I am from Russia, but from Moscow there are about 50 ping, from Ukraine about 20-30
    With such a ping should not be such freezes in the game.
     
  8. Incorrect Username

    Joined:
    Dec 27, 2011
    Messages:
    6
    Turbo Boost would probably help. Have you done a speedtest of actual transfer rate? OVH is usually just 100mbps.

    It was hard to understand what you said. In that image both your minecraft and terraria servers were running at the same time. Bungeecord is pretty network/resource intensive. So if you have no CRON or startup setup try rebooting and only starting up the terraria server. And see how bad the lag is. What other things do you run on yoru VPS? Have you tried reducing nice priority?

    *edit* Would probably be better to just to have a windows VPS for Terraria with mono you will have some lag, depending on your hardware. That CPU you have is on the lower end then the latest Xeon E3 that a host like NFO supplies for a VPS.
     
    #8 Incorrect Username, Dec 9, 2018 at 1:04 PM
    Last edited: Dec 9, 2018 at 3:34 PM