1. These forums are being retired. Please ask all questions and help threads and any other type of discussions on GitHub. During this time, new threads and user registrations have been disabled.

Startup issue

Discussion in 'Linux Support' started by SwordSWD, May 4, 2019.

  1. SwordSWD

    SwordSWD Level 0

    Joined:
    May 4, 2019
    Messages:
    1
    i have no idea what is problem is but I keep getting this error
    TerrariaAPI Version: 2.1.0.0 (Protocol v1.3.5.3 (194), OTAPI 1.3.5.3)
    [Server API] Error Startup aborted due to an exception in the Server API initialization:
    System.InvalidOperationException: Failed to load assembly "MySql.Data.dll". ---> System.Reflection.ReflectionTypeLoadException: The classes in the module cannot be loaded.
    at (wrapper managed-to-native) System.Reflection.Assembly:GetTypes (System.Reflection.Assembly,bool)
    at System.Reflection.Assembly.GetExportedTypes () [0x00000] in <1170fb08300b4d0db71c1d1db8555768>:0
    at TerrariaApi.Server.ServerApi.LoadPlugins () [0x000fa] in <dbe9cd2e9eff467eb81ce247e7a9b53d>:0
    --- End of inner exception stack trace ---
    at TerrariaApi.Server.ServerApi.LoadPlugins () [0x00256] in <dbe9cd2e9eff467eb81ce247e7a9b53d>:0
    at TerrariaApi.Server.ServerApi.Initialize (System.String[] commandLineArgs, Terraria.Main game) [0x00110] in <dbe9cd2e9eff467eb81ce247e7a9b53d>:0
    at TerrariaApi.Server.HookManager.InitialiseAPI () [0x0004e] in <dbe9cd2e9eff467eb81ce247e7a9b53d>:0
    I am using LinuxGSM