TShock 4.2.5 for Terraria 1.2.4.1

Discussion in 'TShock Releases' started by nicatronTg, Feb 21, 2015.

  1. nicatronTg

    nicatronTg Shank / hakusaro
    TShock Founder TShock Admin

    Joined:
    Jul 21, 2011
    Messages:
    715
    This is TShock for Terraria, 4.2.5 for Terraria 1.2.4.1. Also, check out the new plugin section, complete with XenForo resource manager, and a spiffy new set of forums! Plugin authors, please create new resources using resource manager as soon as possible. The old forums will be removed soon!

    Changes include:
    • The automatic update checker is now powered by mimic, and works on Mono without using the infamous Mozroots workaround (#836).
    • REST now supports using UTF-8 in order to support Terraria's newly added support for UTF-8 (#858).
    • The group management system no longer creates the default groups if they aren't present (feel free to delete vip and admin without hassle now).
    • The /user commands no longer have success and then fail afterwards or silently (#543).
    • Add account create & delete hooks (#859).
    • The update manager no longer shuts down after a single failed request. If it fails a request, it decreases the retry time to 5 minutes to attempt to get a better retry sooner rather than later.
    Download here: https://github.com/NyxStudios/TShock/releases/tag/v4.2.5
     
    • Like Like x 4
  2. hiarni

    Plugin Developer

    Joined:
    Mar 14, 2014
    Messages:
    127
    Thanks! :)

    but... getting a ton of Database(sqlite/mysql) - Warnings AND Errors... (fixed them with recompiling the PlugIns with the newest build)
    but! also something like that...? never seen before :S (on a running server)

    (removed)

    EDIT:
    Yes... that was it Wight! Just updated "Code Contracts NET / CCRewrite" and recompiled "Protector" and "House Regions" now it's working like before this update thanks! :)
     
    #2 hiarni, Feb 22, 2015
    Last edited: Feb 22, 2015
  3. Wight

    Wight Administrator
    TShock Admin TShock Mod Plugin Developer Zero Day Plugin Author

    Joined:
    May 20, 2012
    Messages:
    1,597
    That's from the Protector plugin. Post in the thread relevant to it.
    (Code Contracts outdated? Maybe you need it installed on your system. Dunno, I don't speak German)
     
    • Like Like x 1
  4. GrandPa-G

    GrandPa-G Developer of many plugins
    Plugin Developer Zero Day Plugin Author

    Joined:
    Jan 4, 2015
    Messages:
    400
    I don't know if would help, but having the zip file with a version number in the file name makes it a bit easier to know what zip goes with what release. Having said that, I know it is a pain to do and I don't with my own releases.
     
  5. nicatronTg

    nicatronTg Shank / hakusaro
    TShock Founder TShock Admin

    Joined:
    Jul 21, 2011
    Messages:
    715
    Update to the newest release (4.2.6)!

    Probably doable (and easy) if we splice in the tag name. @Olink is the one who wrote the deployment script, so he would know.
     
  6. hiarni

    Plugin Developer

    Joined:
    Mar 14, 2014
    Messages:
    127
    well...
    but is it just a "fix/update" for now(?) or more like a prostective future?
    i mean - if you leave EnsureExists with future updates?
     
  7. nicatronTg

    nicatronTg Shank / hakusaro
    TShock Founder TShock Admin

    Joined:
    Jul 21, 2011
    Messages:
    715
    Plugin developers have been warned of a feature deprecation and should upgrade. That's the point of deprecation versus flat out breaking something.
     
    • Like Like x 1
  8. nicatronTg

    nicatronTg Shank / hakusaro
    TShock Founder TShock Admin

    Joined:
    Jul 21, 2011
    Messages:
    715
    This change will happen for future releases, and was added in this commit to the build deployment script.
     
  9. XGhozt

    Plugin Developer

    Joined:
    May 12, 2012
    Messages:
    171
    Thanks for the update! :)
     
    • Like Like x 1