1. These forums are still being retired! Please use GitHub discussions or Discord. You cannot create new threads or new accounts now. If you need to contact some user of the forums, you should do it sooner, rather than later. This notice was last updated on May 30th, 2021.

Resolved TShock 4.2 Connection Issues (Losing Connection Repeatedly)

Discussion in 'Help and Support' started by Zec, Oct 1, 2013.

Thread Status:
Not open for further replies.
  1. Zec

    Zec Level 0

    Joined:
    Oct 1, 2013
    Messages:
    1
    Hi,

    I'm playing Terraria with my friend and we're having some problems with sustaining our connectivity. He's using Linux Mint 15, playing Terraria through PlayOnLinux and I'm playing with Windows 7. The only way that we managed to start a server that we both managed to get into was that he's hosting it through TShock, and I'm playing as a client.

    The issue is that I (the remote client) am getting disconnected quite frequently. The view I get is that he stops moving and after 20 seconds or so I get thrown out. I can still kill monsters (and he sees me doing it) while I'm disconnecting. He also still sees my character moving according to my input until the very moment that I get disconnected. He seems to have no connectivity issues.

    Any thoughts on this issue?

    Thanks in advance,
    Fredrik Haraldsson
     
  2. Krejza9

    Krejza9 Level 0

    Joined:
    Oct 1, 2013
    Messages:
    4
    Why do not you use a mono ?
    PlayOnLinux is not god solution.
     
  3. nicatronTg

    nicatronTg Shank / hakusaro
    TShock Founder TShock Admin

    Joined:
    Jul 21, 2011
    Messages:
    723
    Please see the Linux support forum for support & issues using Terraria and its server counterpart on Linux.
     
Thread Status:
Not open for further replies.