1. These forums are still being retired! Please use GitHub discussions or Discord. You cannot create new threads or new accounts now. If you need to contact some user of the forums, you should do it sooner, rather than later. This notice was last updated on May 30th, 2021.

Tshock is no longer working?

Discussion in 'Help and Support' started by (xCuz)ThamptonDaMatador, Dec 9, 2013.

  1. (xCuz)ThamptonDaMatador

    Joined:
    Dec 9, 2013
    Messages:
    17
    So, I have been playing Terraria and people have been able to join... until now. My friends and I were playing one day, and then the next my IP wouldn't let them join. I'm using my external IP and I'm not using Hamachi. I do not understand anything that's going on here. There are no logs and I have tried many things. Any possible answers/suggestion to what is going on here? Thank you.:)
     
  2. Olink

    Olink Admin note: Actually a really nice person now

    Joined:
    Jul 21, 2011
    Messages:
    1,397
    Your IP changed, congrats!
     
  3. (xCuz)ThamptonDaMatador

    Joined:
    Dec 9, 2013
    Messages:
    17
    Is there anything I can do about it though?
     
  4. Kjkillercom

    Kjkillercom Level 8

    Joined:
    Oct 18, 2013
    Messages:
    247
    Look up your new external IP here then tell it to the players.
     
  5. (xCuz)ThamptonDaMatador

    Joined:
    Dec 9, 2013
    Messages:
    17
    I don't quite have a new one yet. I'm working on that because I have Windows 8 and I'm trying to make a new one. Actually now that I think about it, I don't even know how to. Sorry for the trouble.
     
  6. Wolfe

    Wolfe Level 9

    Joined:
    Jan 3, 2012
    Messages:
    386
    You don't make your IP's, they're automatically assigned to you.
     
  7. (xCuz)ThamptonDaMatador

    Joined:
    Dec 9, 2013
    Messages:
    17
    I'm sorry but that doesn't go with me. I said that my IP doesn't work.
     
  8. (xCuz)ThamptonDaMatador

    Joined:
    Dec 9, 2013
    Messages:
    17
    Hmmm... on my command prompt it says it isn't using the external IP, but the internal for some reason. Edit: I can't even join my own server now. This is getting pretty ridiculous and very irritating. I need someone that knows more about this than me. I know nothing so anyone that does.
     
  9. Olink

    Olink Admin note: Actually a really nice person now

    Joined:
    Jul 21, 2011
    Messages:
    1,397
    You ignored the one person talking to you, so you probably wont get any more help here.
     
  10. (xCuz)ThamptonDaMatador

    Joined:
    Dec 9, 2013
    Messages:
    17
    I guess I'll just close the thread if that is the case. I understood what he said it's just I don't have a new IP.
     
  11. Kjkillercom

    Kjkillercom Level 8

    Joined:
    Oct 18, 2013
    Messages:
    247
    Edit: Nevermind. You already have the info you need to get it working, but go ahead and keep ignoring us.
     
  12. (xCuz)ThamptonDaMatador

    Joined:
    Dec 9, 2013
    Messages:
    17
    I haven't been ignoring you. I guess you don't understand what I'm saying. I know my IP and it worked before. It doesn't work now. My IP used to work and it hasn't changed. I'm still working out this problem and have got nothing that is helping me solve it. I know what you are saying, but do you understand what I am saying?
     
  13. MarioE

    TShock Admin TShock Mod Plugin Developer

    Joined:
    May 26, 2012
    Messages:
    383
    Perhaps your local IP changed and the port forwarding rule is no longer valid?
     
  14. (xCuz)ThamptonDaMatador

    Joined:
    Dec 9, 2013
    Messages:
    17
    Hmmmm... possibly. From what I see though it has not. However, while I was screwing around with making an IP, I appeared to have messed up my DNS while at it. :oops: I am working on fixing my DNS but I will consider that very likely.
     
  15. (xCuz)ThamptonDaMatador

    Joined:
    Dec 9, 2013
    Messages:
    17
    :( I seem to be having many problems even with trying to flush my DNS. It is even worse since I can't copy what it says on it. While I was on the internet I heard about the HOST files possibly not working. Maybe I can back-date my computer to fix the DNS problem?
     
  16. Kjkillercom

    Kjkillercom Level 8

    Joined:
    Oct 18, 2013
    Messages:
    247
    Are you browsing this site on the computer that you are trying to host Tshock on? If yes then try going into a command prompt and use ipconfig to find your current network IP. Make sure that it matches the one that set in the port forwarding setting for your router. Chances are that your router assigned a new network address to the computer and thus making the current port forwarding settings moot.
    If no, is that computer having trouble connecting to the internet?
     
  17. (xCuz)ThamptonDaMatador

    Joined:
    Dec 9, 2013
    Messages:
    17
    I'm currently using a different computer. I believe what you are saying may be the problem but I'm not sure. I remember that my port is closed but it worked. Currently I'm trying to use a rule to port forward but I do not know how to make a right one or use it for the game which is Terraria. This is so.... I don't even know anymore.
     
  18. Kjkillercom

    Kjkillercom Level 8

    Joined:
    Oct 18, 2013
    Messages:
    247
    Install this plug-in and restart Tshock. See if players can then connect to the server.
     
  19. (xCuz)ThamptonDaMatador

    Joined:
    Dec 9, 2013
    Messages:
    17
    What about the loss of internet though? They won't be able to join if I don't have internet. Edit: I'll search the internet for that.
     
  20. (xCuz)ThamptonDaMatador

    Joined:
    Dec 9, 2013
    Messages:
    17
    Ok finally I'm back on my computer and DNS is working. Now, back to business. How do I use this? Do I install it or open it with some kind of software? Sorry, I derped there. Where do I install it though? Just to the directory of Tshock correct? Edit: I found where to put it. I will see today if people can join. If not, what would be the next step to fixing this?